View Full Version : Sunroof Wind Deflector Buzz

10-30-2008, 02:09 AM
I found that when I run 70 mph with my H2 into a 25 mph or greater headwind (95 mph of wind over the deflector) the factory air deflector on the sunroof buzzes and vibrates loudly against the roof. Has anyone else had this problem and is there a fix?

10-30-2008, 02:31 AM
Have you checked the side pillar plastic trim? It's a known defect that they get loose and you'd swear the sound was coming from the sunroof deflector.

Check your side trim pieces... 10 bucks says the two sided tape let loose.


10-30-2008, 03:53 PM
Yeh i was in the same boat, i always thought it was the roof aswell but its not its those damn pillar i gorilla glued mine. Time for a new windsheild i cracked mine putting my 11 foot stand up paddleboard in my hummer, yes it did fit but i didnt have it in there right and when i closed the rear hatch it pushed it into the windsheild.

10-30-2008, 11:41 PM
Is that the almost vertical black plastic piece by the front windshield pillar (2 ft. long)?

10-31-2008, 12:07 AM
Does anyone have a pic of the section that you refastened? Mine seem secure but I get the "sunroof" buzz.

10-31-2008, 01:21 AM
Yeah mine does it too and drives me insane and does it at way lower speeds like 25+ when it is wet or has rained and residual water is in a crack or somewhere, Absolutely drives me nutts. I thought it was the trimming around the sun visor too. Can someone post a pic of which piece than makes the noise?


10-31-2008, 01:43 AM
Yup, the 2 black plastic trims on the sides of the windshield. One screw is hidden behind the rubber door trim, the other I think you need to pop your fake air cover to access.

Either double sided tape, RTV silicone, or the black mastic that mirror guys use will cure the buzz.

Leaking is prob something else. Most common culprit are blocked sunroof drain holes (if you have sunroof), and the front marker lights (use black RTV silicone).

10-31-2008, 03:25 AM
My H2 just started doing that this summer at about 75 mph, and I thought it was the sunroof wind deflector too. This summer I had the windshield replaced and apparently the didn't tack down those pieces. I've been trying everything, including pieces of rubber under the sunroof air deflector. Tonight I took off the plastic windshield trim pieces, glued them down with mastic, did a high speed 90 mph highway run and voila - NO NOISE ANYMORE - THANK YOU THANK YOU THANK YOU!
Before I read this post I would have sworn it was the sunroof deflector.

11-03-2008, 02:54 AM
My H2 just started doing the same thing. After reading this thread, I went and checked the trim pieces....mine were secured. Figured I better check the sunroof deflector. Sure enough, one corner was loose. I used weather stripping adhesive to glue it back down...no problems since.

11-03-2008, 10:41 PM
Thanks for the info as our H2 makes the same noise when we are driving a certain speed. We are looking into these suggestions. Thanks all.