Hummer Forums by Elcova  
Forums - Home
Source Decals

Source Motors
Custom. Accessories.

H2 Accessories
H3 Accessories
Other Vehicles

H2 Source

H2 Member Photos
H2 Owners Map
H2 Classifieds
H2 Photo Gallery
SUT Photo Gallery
H2 Details

H2 Club

Chapters
Application

H3 Source

H3 Member Photos
H3 Classifieds
H3 Photo Gallery
H3 Owners Map
H3 Details
H3T Concept

H1 Source

H1 Member Photos
H1 Classifieds
H1 Photo Gallery
H1 Details

General Info

Hummer Dealers
Contact
Advertise

Sponsored Ads










 


Source Motors - custom. accessories.


Go Back   Hummer Forums by Elcova > Hummer H1 Discussion Forums > General H1 Discussion

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11-23-2014, 07:18 AM
3Hummer's Avatar
3Hummer 3Hummer is offline
Hummer Guru
 
Join Date: Dec 2006
Posts: 2,195
3Hummer is on a distinguished road
Default Possible CTIS and coolant leak. please help!

Alright guys

First CTIS:
So I think my truck has a leak in the CTIS system. I recently came back to my truck from a few day trip and the tire pressure was down to about 10 PSI in the front tires only! The back were fine. I re-inflated the tires. drove home. Parked it overnight, lost only a few PSI (it was cold so that could be it) and then drove it back to the airport and now I'm out of town again for a few days. If its low again when I get back I have reason to believe its a leak in the CTIS system as both front tires were low the first time I don't think its a nail or something else causing a flat. Any advice on what this may be or what to look for? I'm not technically savvy so if it happens again I'm just going to have to take it in for service unless someone can give me some advice on what to look for.

Second the coolant.
I walked outside one afternoon and saw some coolant on the ground below my truck (some green fluid) I turned the car around, opened the hood and couldn't find where exactly it was dripping from and the coolant level seemed to be in the normal place just barely below the fill line. I did not notice any more coolant on the ground that day or the next morning. Again drove the truck to the airport and out of town for a few days. Came back to the truck notice no spots on the ground, opened the hood checked the coolant level it was still in the same place. Drove it the entire next day without noticing anything and then That night on the ground i noticed a very minimal amount again (maybe about two quarters size). Again moved the truck and again the next day checked the coolant level and it was fine. Next morning noticed nothing on the ground before i left for the airport and checked the level and it was still in the same place. So now I'm out of town again as I've said above so ill check it again when i get back to the truck. But what should i be looking for exactly? Is it normal with some serious temperature changes for something like this to happen (its at my place in Charlotte, NC and recently the temperatures have been fairly warm one day, then drop to freezing for a day then back up and so on) If I see more or no advice on it I'll have to take it in for this as well.

Thanks your help is greatly appreciated!
__________________

2003 H1 HMCS: Ocean Blue Metallic, Grey Leather Interior

2010 H3 Alpha: Canyon Metallic, Cashmere Interior

2017 VW Jetta S

2012 Cessna 182T Skylane

used to have: 2007 base H3 Slate Blue

/''T''|[___|___]
[---T--L -OlllllllO-]
()_)"""()_)/"**"\)_)
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 02:04 PM.


Powered by vBulletin Version 3.0.7
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.