Hummer Forums by Elcova  
Forums - Home
Source Decals

Source Motors
Custom. Accessories.

H2 Accessories
H3 Accessories
Other Vehicles

H2 Source

H2 Member Photos
H2 Owners Map
H2 Classifieds
H2 Photo Gallery
SUT Photo Gallery
H2 Details

H2 Club

Chapters
Application

H3 Source

H3 Member Photos
H3 Classifieds
H3 Photo Gallery
H3 Owners Map
H3 Details
H3T Concept

H1 Source

H1 Member Photos
H1 Classifieds
H1 Photo Gallery
H1 Details

General Info

Hummer Dealers
Contact
Advertise

Sponsored Ads










 


Source Motors - custom. accessories.


Go Back   Hummer Forums by Elcova > Hummer H2 Discussion Forums > Technical Discussion and Customizing your H2

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11-14-2008, 06:09 AM
aussieh2 aussieh2 is offline
Hummer Novice
 
Join Date: Oct 2006
Posts: 17
aussieh2 is on a distinguished road
Default 2008 no start

Greetings all, i'm having a problem with my 08 h2 where it cranks but wont start, the Tech 2 says fault code U0109, not reading FPCM (fuel pump control module, i have checked fuses and replaced the PCM, however, still no luck
any clues from you guys as there are no GM dealers here in AU for the H2 so i'm at a bit of a stop, plus it is no good in my garage with all that beach just 30 miles away.
cheers
Brenton
Reply With Quote
  #2  
Old 11-14-2008, 02:33 PM
Planohummer Planohummer is offline
Hummer Veteran
 
Join Date: Aug 2005
Posts: 184
Planohummer is an unknown quantity at this point
Default Re: 2008 no start

check two areas:
1)behind fuse block on driver end of dash, connector at top right that's not clicked into place
2)there are two metal snap clips holding trans harness to side of trans. they're on the metal shielded cable area. make sure neither is cutting into the harness.
The u0109 indicates no communication between PCM and FPCM, not necessarily a fault in either module.
Reply With Quote
  #3  
Old 11-14-2008, 10:57 PM
Yetti Yetti is offline
Hummer Expert
 
Join Date: Apr 2004
Location: Grass Lake,Mi
Posts: 583
Yetti is an unknown quantity at this point
Default Re: 2008 no start

I would be looking to see if your harness grounds are in tact. search for all that you can find. I have a hunch one is loose and is not letting the controller talk. there should be one on the frame just rear of the tank and one under the engine on the left side if I remember right.
__________________
Yetti
----------------------------
www.greatlakes4x4.com
www.wegotmud.com
www.glfwda.org
Reply With Quote
  #4  
Old 11-15-2008, 12:35 AM
HUMTECH's Avatar
HUMTECH HUMTECH is offline
Hummer Authority
 
Join Date: Sep 2003
Location: Canada
Posts: 1,226
HUMTECH is an unknown quantity at this point
Default Re: 2008 no start

Can you communicate with the fpcm with the tech 2? Do you have air suspension, if so can you communicate with the air suspension module? The air susp module is the last module in the high speed lan circuit before the terminating resistor, if you can communicate with it likely you have a fault with the fpcm itself, or its ground or power. If you cannot communicate with the air suspension module you need to test the high speed lan circuits for a short or open, still could be a fault in the fpcm. Try to scan all modules in the truck and see what, if any, you have no communication with. From there i may be able to help a little more.
Reply With Quote
  #5  
Old 11-15-2008, 12:53 AM
aussieh2 aussieh2 is offline
Hummer Novice
 
Join Date: Oct 2006
Posts: 17
aussieh2 is on a distinguished road
Default Re: 2008 no start

Thanks for that guys, i've found the problem, i had a think about it last night and thought that no communication with the Tech II means the FPCM is not getting power or a ground, so i traced the wire from the fuse block under the hood and did a continuity test, i got down to the last inch of wire going into the FPCM module and there was the problem, the wire had separated from the socket inside the plug, even though the terminal was still inside the plug, reattached it and its all a go now, thanks for all your input.

PS here is a pic of a RHD H2 it took 6 months to finish
Attached Images
 

Last edited by aussieh2 : 11-15-2008 at 12:57 AM.
Reply With Quote
  #6  
Old 11-15-2008, 07:26 PM
funnone's Avatar
funnone funnone is offline
Hummer Veteran
 
Join Date: Oct 2008
Posts: 51
funnone is on a distinguished road
Default Re: 2008 no start

Reply With Quote
  #7  
Old 11-17-2008, 11:18 AM
aussieh2 aussieh2 is offline
Hummer Novice
 
Join Date: Oct 2006
Posts: 17
aussieh2 is on a distinguished road
Default Re: 2008 no start

hmmm, not sure what a dancing banana means....Queensland where i live is known as the banana state, beacause that is where most of the banana plantation's in australia are situated! but thanks anyway
Reply With Quote
  #8  
Old 11-17-2008, 04:16 PM
brad_p's Avatar
brad_p brad_p is offline
Hummer Expert
 
Join Date: Aug 2007
Location: Lake Charles, Louisiana
Posts: 622
brad_p is on a distinguished road
Default Re: 2008 no start

hahah that looks odd seeing it all reverse.
__________________
2006 Slate Blue H2- on 20 inch Rockstars, BFG KM2's 37x12.50, Gobi Rack, Piaa lighting.
----------o-o-o-o-
[[_]|[]|[][___]
[---\-|-----[ -OIIIIIIIO-]
"(O) ) ---- (O) )/"H2"\) )
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 02:31 AM.


Powered by vBulletin Version 3.0.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.